Custom Widget Not Showing Up

I am following this course: I go through the step of creating the Custom Widget in section 3.2. I does create. I can see it in /CustomWidgets/textBox/dist/1.0.0/mendix.TextBox.mpk However… when I start npm… either npm start or npm run dev, do an F4 in Mendix version 10, I dont see the widget show up when I right click and choose “Add widget”. A co-worker of mine followed these same steps and she can see it. I also tried npm run build as well. Is there some other way I should be refreshing this to be able to see it? Thanks!
2 answers

Hi Blake,

Have you tried synchronizing your app directory in the Mendix Modeler?

App > Synchronize App Directory (F4)


Ok…. got it fixed!  Instead of following the instructions I made the following changes:

Changed “Mendix project path” from ./tests/TestProject to: “../../”

Changed from “Class Components” to “Functional Components”

Not sure which one fixed it. Maybe the path. Since ./tests does not exist?


Thanks for the other comments!