Excel Export

Hi, I used the export to excel button to export a data grid but it does not work reliably. It works sometimes and sometimes not. Do you know if this is a Mendix bug or do you have any suggestions to solve this problem ? Kind regards Enis
6 answers

Hello Enis,

It might be a Mendix bug, make sure to report it via a ticket.

You can also try the excel exporter app store module as an alternative if you can’t get exports done through the default buttons.

Hope this helps.


Hi Enis,

 I believe we will need more data to pinpoint exactly what is going wrong for you. When the export doesn't work, what does the user see? Is there a message in the application log? Does the user see the message 'an error has occured please contact your system administrator?' If it is the latter, then you should see some error message in the console that will provide more insight. If the application appears to do nothing, then perhaps the issue is on the browser side. Using the browser console, usually activated by hitting f12, would also provide more debugging information.



I am not sure if the screenshot above is related to export to excel.  Did you check and see if the browser permits file downloads?  Sometimes file downloads are blocked for certain websites.  If so, you’ll typically see an indicator that a download was blocked in the address or menu bar of your browser.

Can you provide some more information about when it doesn’t work?  I.e.,

  • does it always work for a given user
  • does it work sometimes for a given user
  • does the success of the download seem related to how many rows are being downloaded
  • can you try the download with a small sample of data and see if that works all the time/for all users

More info will help to troubleshoot.


  • A small progress bar opens. Execution is running and when showing 100% window/bar is closing. Looks OK
  • No errormessage
  • Errordump in Console:


Dear all,

I am working with Enis together on the same project, so let me give you more details on that issue which just appeared a few weeks ago out of nothing – we didn’t make any changes on the excel export. And we are using the standard “excel export” feature of data grids.

  1. This issue doesn’t appear in the localhost and also not in the Testsystem (SAP Cloud Plattform Cloud Foundry), but in the Productive system (also SCP Cloud Foundry). The Q- and Prod-system have exactly the same configuration – as I am aware of.
  2. The only difference between Q- and Prod-system is the data
  3. This issue seems to appear sometimes. It has no dependency to any browser (tried with Firefox, Safari, IE, Chrome) – they all act in the same behaviour. 
  4. The browser debug console outputs that what Enis already mentioned above
  5. Please find below the SCP Log in regards of the excel export issue
  6. I tracked some steps and tried to analyze if there is a structure in the behaviour of the excel export issue – for me it doesn’t seems like that. Find below the steps:
    1. Opened VIew with DataGrid, clicked on export, download not possible (errors are always the same – there is a loading bar, but no excel will be downloaded, no error message, only error appears is in the SCP log console and in the debugger console of the browser)
    2. Filtered table with anysearch, export worked
    3. Kept filtered view open, clicked on export, worked – tried 3 times, worked
    4. Removed filter, clicked on export, it didn’t work
    5. Setting same filter, clicked on export, it didn’t work
    6. The same filter is still set, clicked a second time on export, it worked
    7. The same filter is still set, clicked a third time on export, it worked
    8. Removed filter, clicked on export, it didn’t work
    9. Tried three times to click on export, it didn’t work
    10. Set the filter again, export worked
    11. Clicked on export second time, it worked
    12. Reloaded page (which automatically removed all filters), it worked
    13. Kept page open and clicked second time on export, it didn’t work – third time also didn’t work
    14. Set the filter again (same as before), it didn’t work
    15. Filter is still set, excel export didn’t work second time
    16. Filter is still set, excel export worked third time


2019-09-24T14:25:01.180+0000 [APP/PROC/WEB/0] OUT ERROR - Connector: The file 'export_grid_e875caf4-04f6-4146-b2f7-518674e4a8bc.xls' could not be found.
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT ERROR - Connector: com.mendix.storage.FileNotFoundInStorageException: LocalFileSystemStore:: File does not exist for key: edb4a86a-2b6b-42aa-80de-62b1d2678afd
2019-09-24T14:25:01.181+0000 [RTR/5] OUT "just deleted the host adress here" - [2019-09-24T14:25:01.173+0000] "GET /file?guid=26177172834098974&changedDate=1569335098854&name=export_grid_e875caf4-04f6-4146-b2f7-518674e4a8bc.xls&target=internal HTTP/1.1" 560 0 190 ""just deleted the host adress here" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36" "-" "" x_forwarded_for:"-" x_forwarded_proto:"https" vcap_request_id:"6411fcfb-5682-40c1-7362-113d4b1bf87b" response_time:0.007439952 app_id:"277cc38f-aeb1-44ee-abe6-47f46966c6cd" app_index:"0" x_correlationid:"-" tenantid:"-" x_b3_traceid:"b0e15b765b2b3786" x_b3_spanid:"b0e15b765b2b3786" x_b3_parentspanid:"-" b3:"b0e15b765b2b3786-b0e15b765b2b3786"

2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.storage.localfilesystem.internal.LocalFileSystemStore.getFileDocumentAsFile(LocalFileSystemStore.scala:150)
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.storage.localfilesystem.internal.LocalFileSystemStore.getStoredSize(LocalFileSystemStore.scala:156)
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.storage.localfilesystem.internal.LocalFileSystemStore.getContentLength(LocalFileSystemStore.scala:160)
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.filedocumentprocessor.internal.FileDocumentProcessorImpl.getFileDocumentFileLength(FileDocumentProcessorImpl.java:109)
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.webui.requesthandling.FileRequestHandler.getContentLength(FileRequestHandler.scala:390)
2019-09-24T14:25:01.181+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.webui.requesthandling.FileRequestHandler.doDownload(FileRequestHandler.scala:290)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.webui.requesthandling.FileRequestHandler.handleDownload(FileRequestHandler.scala:278)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.webui.requesthandling.FileRequestHandler.handleRequest(FileRequestHandler.scala:69)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.webui.requesthandling.FileRequestHandler.processRequest(FileRequestHandler.scala:60)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.externalinterface.connector.RequestHandler.doProcessRequest(RequestHandler.java:40)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.external.connector.MxRuntimeConnector$1.execute(MxRuntimeConnector.java:72)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.external.connector.MxRuntimeConnector$1.execute(MxRuntimeConnector.java:69)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.util.classloading.Runner.doRunUsingClassLoaderOf(Runner.java:32)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.external.connector.MxRuntimeConnector.processRequest(MxRuntimeConnector.java:75)
2019-09-24T14:25:01.182+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.basis.impl.MxRuntimeImpl.processRequest(MxRuntimeImpl.java:909)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at com.mendix.m2ee.appcontainer.server.handler.RuntimeHandler.service(RuntimeHandler.java:42)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:867)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:542)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:255)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:1588)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:255)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1345)
2019-09-24T14:25:01.183+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:203)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:480)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:1557)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:201)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1247)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:144)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:132)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.Server.handle(Server.java:502)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:364)
2019-09-24T14:25:01.184+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:260)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:305)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:118)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:333)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:310)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:168)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:126)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:366)
2019-09-24T14:25:01.185+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:765)
2019-09-24T14:25:01.186+0000 [APP/PROC/WEB/0] OUT 	at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:683)
2019-09-24T14:25:01.186+0000 [APP/PROC/WEB/0] OUT 	at java.lang.Thread.run(Thread.java:748)



Hi all,

we just solved the issue.

On the SAP Cloud Platform we used 2 instances for the application. With that the excel export function didn’t work properly. After removing the second instance the excel export function is working appropriate now :) Don’t know if this is an bug.

Best regards,