Text area size properties do not have any effect in app

In my app on a number of positions I use text areas. In the properties I changed the ‘Number of lines’ property to 15 lines. When I run my app, the text area is shown with three lines and a scroll bar.  I tried property ‘Grow automatically’ set to ‘Yes’, this also does not have any effect on the size of the text area. I found an older post about problems with text areas, but the solution in this, also does not work for me. https://community.mendix.com/link/questions/92449 Any ideas ?
2 answers

Hi Chris, I just tried in Mendix 8.4.1 and there it works without problems. Maybe you can try another Mendix version to test?

Edit 1: I just ran into the same issue while developing and found out that there is a bug in Atlas UI. The reason is that in the latest Atlas UI version the CSS rule display: flex; is set on the .form-group class and flex-direction: column; on .form-group.no-columns:not(.label-after). 

The fix for me is to add the following to my custom scss: 

textarea.form-control {
    flex: auto;



Hi there, 

I am using 8.15.2  and having plain standard Atlas UI with the same behavior. Text Area General → 8 lines and displayed are 2 lines. Did anyone of you found a fix or already filed a support ticket for it?