Select button in data grid not working

I am using a data grid with the select button and it is now acting as a back button rather than selecting. It was working a few days ago, and now it doesn’t and I have no idea as to why. I have changed nothing on that page, and it is the default select button with nothing custom added to it.
2 answers

Can you show us some screenshots of the page, the button and its properties.

Can you tell about what you tried to solve this riddle.

Try changing the default button of the datagrid.

Try deleting the button and creating a new one for it.

Try to replicate this behaviour in a newly created page and datagrid.

Fiddling around like this will probably get you closer to the solution, maybe even solve it.


I have tried creating a new select button, I tried switching the default button, and even went as far as to recreate the whole page, and the issue persists. So it is not locked to the page itself, but rather seems to be an issue in general.

Edit: On a completely separate project the problem is still there