Hey Tomasz, thanks for bringing this to our attention.
Unfortunatly your case doesn't seem as straight forward to just change it to 256, if you have a look at the documentation there is a note that the 256 is incorrect. I personally don't know the specifics of this attribute but I'll write it down to investigate later to see what is the proper solution.
The main problem with these kind of cases is that if the attribute does contain more characters in Teamcenter, Mendix will throw an error during the retrieve because of the character limit.